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Outline of today’s presentation

1. What is Rmd and why/when is it useful?

2. Introduction to using Rmd

3. Further applications of Rmd
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Part 1: Part 1:   
What is Rmd and why/when is it useful?What is Rmd and why/when is it useful?
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The data science process

source: R for Data Science by Garrett Grolemund & Hadley Wickham
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https://r4ds.had.co.nz/


The user's perspective on Rmd

6 / 56



Work�ow: What's behind Rmd?
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Starting from behind: What's the outcome?
Let's have a look at the default Rmd-example in RStudio.

See some examples of Rmd-applications and possible output
formats at the R-Studio Gallery.
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https://rmarkdown.rstudio.com/gallery.html


Overview of the output-formats
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What purposes is Rmd for?
(according to Hadley Wickham)

Communication with decision makers

Collaboration with other data scientists

Modern notepad

reproducibility
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Advantages: Why using Rmd?
Better comprehensibility

Ease of usage

"on the way"-usage (documentation)

easy to learn

Power of usage

multiple occassions

multiple output-formats (+ possibility to switch)

compatibility with other "languages"
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When is Rmd not recommended?
In general: The less need for communication the less is Rmd
recommended
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Part 2: Part 2:   
Introduction to using RmdIntroduction to using Rmd
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Let's start using Rmd!
Creating a new Rmd-�le

Comparison: ".R" vs. ".Rmd"

Three main elements: header, code chunks, markdown-text

Try rendering/knitting your �rst Rmd!
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Creating a new Rmd-�le

File > New File > R Markdown > OK
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Options in the scripts pane

Knit

Settings ⚙

'✔ Preview in Viewer Pane' shows knitted document next to help pane

'Output options' enables easy changes in YAML header concerning the
output document type (e.g. inserting table of contents)

Insert a new code chunk

Several programming languages are possible

⇧ ⇩: Previous/next section or code chunk

Run Code chunks or lines
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The so-called "YAML" header
consists of:

---
title: "Untitled"
author: "Anonymous"
date: "26 4 2019"
output: html_document
---

Multiple options are possible. For
example you can specify the output
document:

---
title: "Untitled"
author: "Anonymous"
date: "26 4 2019"
output: 
   html_document: 
    fig_height: 4
    fig_width: 6
    keep_md: yes
    number_sections: yes
    theme: cosmo
    toc: yes
---

Header
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Exercise 1:
Edit the YAML header of the default html_document

1. Change the document title to "My First Markdown Document" and the
author to your own name.

2. Change the date to a format with dots between the numbers.

3. Include a table of contents and number the section headings.

4. Apply the theme "lumen".
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Text formatting basics
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# header

## header

### header

#### header

Headers
Use # to create headers.

Multiple #’s create lower level headers.
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Text

*italics*

_italics_

**bold**

__bold__

`code`

Text

italics

italics

bold

bold

Formatting narrative text
Text is rendered as plain text. Use asterisks (*) or underscore (_) for italics and
bold format. Use backticks for code.
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Unsorted list:

bullet 1

bullet 2

sub-bullet

Numbered list:

1. item 1

2. item 2

a. sub-item

Lists
Lists need a blank line before they begin. Use asterisks, plus or minus to make
a bullet list. Indent sub bullets with two tabs (   ).
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This is a

[link](https://www.rstudio.com)

This is a link

Hyperlinks
Use brackets to denote a link. Place the URL in parentheses.
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https://www.rstudio.com/


![]
(https://www.rstudio.com/wp-
content/uploads/2014/07/RStudio-
Logo-Blue-Gray-600x211.png)

![](images/logo.png)

Images
Use a link preceded by an exclamation mark to insert an image. The image
can be stored online or locally.
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According to 
Einstein, $E=mc^{2}$.

According to Einstein,
$$E=mc^{2}$$

According to Einstein, .

According to Einstein,

Equations
Write equations with latex math commands and surround them with dollar
signs. You can make inline and block equations.

E = mc
2

E = mc
2
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Comments
Insert a comment with the shortcut: Ctrl + Shift + C

<!-- text text text -->

Text comments will not show in the rendered document.
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Need help?
Help > Markdown Quick Reference
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Need help?
Help > Cheatsheets > R Markdown Cheat Sheet

Help > Cheatsheets > R Markdown Reference Guide
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Exercise 2:
Simple formatting changes in template

1. Change the word “simple” in the first paragraph from plain text to italics.

2. Insert a third level header called “Knit” before the paragraph “When you
click the…”.

3. In the second paragraph, the word “Knit” is bold. Also change the word
“button” to bold.

4. Change the first paragraph. “HTML”, “PDF” and “MS Word documents”
should be the bullets of an unordered list.
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Exercise 3:
Simple changes in the template

1. Create a hyperlink with the clickable text "this website" instead of the URL
< http://rmarkdown.rstudio.com > in the first paragraph.

2. Make a new second order header “Distance” at the end of your document.
Insert the following text below the header.

Driving is the controlled operation and movement of a
motor vehicle. Road speed limits are used to set the
maximum (or minimum, in some cases) speed at which road
vehicles may legally travel on particular stretches of
road.

3. Add the following sentence with the equation displayed inline at the end
of the text.

The equation for driven distance is distance=v*t.
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http://rmarkdown.rstudio.com/


R Code
Inline Code

Code Chunks

Code Chunk Options
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Inline Code
write text and add code
start the code with r and surround it with backticks

Inline code before knitting

Inline code after knitting

This slide was generated at 2019-04-29 09:40:31.

You can also format the inline code.

This slide was generated at 2019-04-29 09:40:31 .
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Manual klicking: Insert > R Short Cut: Ctrl + Alt + I
(Apple: Cmd + Option + I )

Typeing: ``` {r}

        some code

at the end ```

Code chunks
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Code chunk options
label code chunks

echo

results

include

�gure height/width

comment
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Label code chunk
simply specify the name of the chunk

specify the name of the cunk

Practical Tip: knitr provides the option ref.label to refer to previously defined
and labeled code chunks

instead of a label use ref.label

``` {r ref.label='previously code chunk name'}
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Code included

``` {r, echo=True}

head(cars, 3)

##   speed dist
## 1     4    2
## 2     4   10
## 3     7    4

Code not included

``` {r, echo=False}

##   speed dist
## 1     4    2
## 2     4   10
## 3     7    4

Echo
whether to include R source code in the output file
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Results
wether the outputs are shown and where/how

results='markup' (default) mark up using the output hook, e.g. put results
in a special LaTeX environment

results='hold' all output pieces will be displayed at the end of the code

results='hide' no results are appended to the final document

results='asis' results are shown without reformatting them

Include
include=FALSE neither code nor results are displayed (code is run)
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�gure height/width
width and height of the plot in inches default: 7x4 You can change the default
by specifing the figure hight/width, for example: fig.width = 4,
fig.height = 3

plot(pressure)
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Comment (Code Decoration)
comment="##" (default) character string, the string will be appended to the
start of each line of results in the output

default

head(cars)

##   speed dist
## 1     4    2
## 2     4   10
## 3     7    4
## 4     7   22
## 5     8   16
## 6     9   10
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Set default for all code chunks
knitr::opts_chunk$set Setting default globally in the first code chunk of
your document for all following code chunks

knitr::opts_chunk$set(echo=FAlSE)

## 'data.frame':    50 obs. of  2 variables:
##  $ speed: num  4 4 7 7 8 9 10 10 10 11 ...
##  $ dist : num  2 10 4 22 16 10 18 26 34 17 ...

Note: the global default can be overwritten for and in individual chunks

str(cars)

## 'data.frame':    50 obs. of  2 variables:
##  $ speed: num  4 4 7 7 8 9 10 10 10 11 ...
##  $ dist : num  2 10 4 22 16 10 18 26 34 17 ...
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Chunk options via ⚙
drop down menu
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Chunk options via ⚙
change chunk label
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Chunk options via ⚙
other code chunk options

Everything is adapted automatically.
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Exercise 4:
Edit code chunks

1. Edit the setup code chunk so that no code is displayed above results of
any chunk in the document.

2. Look at the code chunk labelled pressure. Consider the changes you
made in the 1st task: What code chunk option is now unnecessary and
why? Delete it.

3. Change the size of the pressure plot. Set the code chunk options for
height (=4) and width (=6).

4. Edit the cars code chunk, which contains the summary of cars. Insert a
chunk option so that ## is not shown in the output table of the final
document.
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Exercise 5:
1. Insert a new code chunk labelled distance that plots a histogram of cars

distance variable. Use this code inside the chunk:

hist(cars$dist, main=NULL, xlab="Distance")

2. Alter the code chunk options (only of this chunk) so the code of the chunk
is shown above the histogram.

3. What happens if you include the code chunk option eval=FALSE ? Try it
out with the distance chunk and read cheatsheet or reference guide. Set
it back to the default option.

4. Inline Code: Write the following sentence beneath the histogram and
substitute xx and yy with two inline r codes:

The figure contains xx distance measurements with a
mean of yy ft.
xx: use length()
yy: use mean()
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Another code chunk option: EVAL
whether to evaluate/run/execute the code chunk

eval=TRUE code is executed eval=FALSE code is not executed

NOTE: a code chunk can conditionally be evaluated via a previously defined
variable

# previously defined variable (evaluate code after a special day)
eval_if = Sys.Date() > '2019-04-10'

mean(cars$dist)

## [1] 42.98
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Part 3: Part 3:   
Further applications of RmdFurther applications of Rmd
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Document Output Formats
html_document

pdf_document

word_document

md_document
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Presentation Output Formats
ioslides_presentation

slidy_presentation

beamer_presentation
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Page Break in Presentation
First or Second Header

---

***
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Knitting
YAML Header -> adapt output type -> knit

drop down menu

knit via console

rmarkdown:: render (“filename.Rmd”)
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Exercise 6:
1. Render a word_document by clicking “Knit to Word”. What change do you

notice in the .Rmd document?

2. How would you render a PDF document by specifying the YAML-header?

3. Render a slidy_presentation and an ioslides_presentation.

4. Some content is not fully displayed. How would you solve this problem?
Show solutions for at least one type of presentation.
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Annotation to Presentations
In ioslides and slidy the possibility to apply custom style is limited. Especially
if you are not an expert in CSS. Besides there have been plenty of issues:

Our presentation is made with xaringan.

Is an R Markdown extension based on the JavaScript library remark.js

Generates HTML5 presentations

The documentation gives an overview of the functions
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https://github.com/rstudio/rmarkdown/issues/730
https://remarkjs.com/
http://slides.yihui.name/xaringan/


Practical Tips
Insert blank lines (e.g. before and after headers) to prevent formatting
errors.

If two spaces do not work with sub-bullets in lists, try four spaces.

Render to PDF: Make sure automatic package download is enabled in your
LaTeX distribution.

Underline text? Depends on output document type:

html: <u>some text</u>
pdf: \underline{some text}
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Exercise 7
Rebuild an html_document
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Thank you for your attention.Thank you for your attention.
Have a nice evening.Have a nice evening.
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